
Learning Guide
Animate 3D Avatars in Unreal Editor for Fortnite

Introduction
An avatar is a representation of a person or character in a digital world. Adding your own animated avatar to a 3D experience is a great way
to make it more personalized.

This Guide will show you how to create a personalized avatar with Ready Player Me, configure it for animation in Blender, and apply an
animation to it with the Mixamo library. Then, you will learn how to add your animated avatar to an island in Unreal Editor for Fortnite
(UEFN).

To achieve the outcomes outlined in this Guide, it is very important that you keep close track of multiple files and use the correct one at each
step. We have provided recommended naming conventions to help you keep track of your files.

Video Learning Guide for this Lesson:
https://www.youtube.com/watch?v=W7fAqA76Ipk
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Prior Knowledge Check
To successfully complete this lesson, you should be familiar with the basics of the UEFN User Interface and be comfortable navigating in
UEFN. Take a look at the Unreal Editor for Fortnite User Interface Basics to familiarize yourself with the interface.

You can also use the Epic Games Documentation for more detailed information on the UEFN User Interface.

Getting Started
Make sure you have Blender and UEFN installed on your computer. Create a new project in UEFN and have an island ready to import your
animations into.

https://createaccess.org/foundational-content
https://dev.epicgames.com/documentation/en-us/uefn/user-interface-reference-for-unreal-editor-for-fortnite
https://www.blender.org/
https://dev.epicgames.com/community/fortnite/getting-started/uefn


Step 1: Understand avatar components

Preview
Avatars can do a lot to make a 3D experience more unique and engaging. However, avatars, by design, have a lot of components that the
creator needs to keep track of. In this section, you will briefly learn about different parts that make up a 3D avatar and how they work.

Experiment

CHARACTER MODEL

A character model is the 3D representation of your avatar
on screen. You can think of the model as the "sculpted
body” of your avatar. The model can include detailed facial
features, clothes, hair, etc. But it cannot be animated to
move like a human without a skeleton, and will look plain
gray without any textures added.

TEXTURES

Textures are image files that define color, detail, or other
surface information of a 3D model. A texture can also
define how the surface of a model reacts to light (shiny,
dull, metallic, etc.). By adding textures to your avatar, you
can visualize the color and details of the hair, skin,
clothing, etc. Many avatar creators, such as Ready Player
Me, add textures to avatars for you.



SKELETON AND BONES

Just like the human body, 3D characters have a collection
of bones and joints inside them that form a skeleton.
As mentioned above, 3D character models cannot be
animated to move their limbs like humans until they have
skeletons.

With the skeleton, each joint can be animated to move the
corresponding parts of the body. Creators can animate
their 3D avatars by animating every single joint by hand, or
they can use 3D animation libraries like Mixamo that will
create a skeleton for a character automatically and allow
the creator to decide how to animate it by providing a
library of options.

ANIMATION FILES

It is important to keep in mind that animations and
skeletons are closely linked together. When you download
an animation file online or create your own animation for
“Character A,” that animation will be dependent on the
skeleton of “Character A.” This means that the same
animation file cannot be used on a different character - for
example, “Character B.”

https://www.mixamo.com


Step 2: Create an avatar in Ready Player Me

Preview
The first step in adding an animated avatar to your UEFN island is to create the avatar. To do this, you can use Ready Player Me, a free
web-based avatar creation tool that offers a multitude of customization options for users.

Experiment

READY PLAYER ME

Go to the https://readyplayer.me website.

Sign up for a free account and pick the Player account
option.

If you’re facing a blank screen, you may need to confirm
your account through a link sent to your email address first.
Use the link on your email, and continue to the Ready
Player Me website.

https://readyplayer.me


Once on the main page, click the Enter HUB button on
top-right. You will be taken to the avatar creation page.

If you don’t see the avatar creation page after entering the
Hub, from the left menu select My Avatars and then select
+Create New Avatar.

Pick one of the default avatars to start editing. You can
also upload your own photo and Ready Player Me will
create an approximate avatar based on the photo that you
can edit.



Use the customization options on the editing page to
change your avatar’s facial features, body and height, hair,
clothing, and more.

Explore the options until you create an avatar that you’d
like to use.

When you’re done editing the avatar, click Next on the
top-right corner of your screen.

To download your avatar, copy the share link on the page
and paste it into your browser. Your avatar will start
downloading automatically as a .glb file.

By default, the file will be saved to the Downloads folder
on your computer. We recommend locating the file and
naming it “[file-name]_TexturesOnly”
(for example: MyAvatar_TexturesOnly.glb)

Self Check
Could you create an avatar that had the features and characteristics you wanted?



Step 3: Configure for animations in Blender

Preview
After creating an avatar in Ready Player Me, you have a 3D model of a character. This section will help you configure your avatar to be
animated in the next steps.

Please carefully note all the different file types and suggested naming conventions in this section.

Experiment

FILE CONVERSION IN BLENDER

Blender is a free 3D creation suite that is commonly used
in industry. Blender is a versatile tool that can be used in
many aspects of 3D creation, but for this lesson, you will
need it briefly to change the file format of your avatar.

Download Blender and follow the prompts to install it on
your computer. Once installed, launch Blender and select
General from the New File options.

https://www.blender.org/download/


You will see some default objects (cube, camera, light) in
the Blender scene that opens. You can delete these
objects since they’re not needed.

Click on the “A” key to select everything in your scene
and press Delete (or the “X” key) to clear the scene.

Import your Ready Player Me avatar into Blender by
selecting File > Import > glTF 2.0 (.glb/gltf), and then
navigating to the folder where the model was downloaded
to your computer from the Ready Player Me website.

Select the file, which should have been named
“[file-name]_TexturesOnly.”



Your avatar will appear in the Viewport. If your avatar
appears gray, you can enable the textures and colors on
the viewport by clicking the Viewport Shading icon in the
top-right corner.

Deselect everything by clicking an empty space in the
Viewport away from your avatar.

In the Scene Collection menu on right, select “Armature”
and hit the “X” Key or Delete on your keyboard to remove
the existing skeleton. We are deleting the Ready Player
Me skeleton because we will be adding a new one in
Mixamo later.

If you see any Icospheres in Scene Collection, delete
those as well.



Export your avatar as an FBX file by selecting File >
Export > .fbx.

We recommend naming the file
“[file-name]_preMixamo”.
(for example: MyAvatar_preMixamo.fbx)

This file is a version of your avatar without “bones” or a
“skeleton.” In the next section, we will show you how to
add a new skeleton to your avatar so it can be animated
using the Mixamo library.

Self Check
Were you able to import your avatar into Blender, edit it as suggested, and export it successfully?



Step 4: Select animations in Mixamo

Preview
Your avatar is now ready to animate. This section will help you select an animation to apply to your avatar to get it ready for import into
UEFN.

Please carefully note all the different file types and suggested naming conventions in this section.

Experiment

UPLOAD TO MIXAMO

Go to mixamo.com and sign up for free using your email.

You will see an avatar on the right and animation
thumbnails on the left. We need to upload our avatar to the
Viewport on the right.

Click the Upload Character button on the top-right, and
select your “[file-name]_preMixamo.fbx” file exported from
Blender.

Once it’s uploaded, hit Next.

https://www.mixamo.com/#/


RIGGING THE MODEL

After uploading your avatar, position the colorful circles
onto your avatar to represent locations of joints by clicking
and dragging them to the appropriate locations. The
system provides a mirror function to simplify this process.
You will see an example on the right side of your screen
that shows where to place each marker.

Click Next to have Mixamo rig the model. This process
might take a few minutes. When done, click Next again.

Before selecting any animations from the left menu, click
the Download button on the top-right. Keep the default
format at “FBX Binary” and select “Original Pose.”

Click Download again and the avatar will download
automatically to your “Downloads” folder. Find the file on
your computer and rename it.

We recommend naming the file “[file-name]_Bones.”
(for example: MyAvatar_Bones.fbx)



Explore the animations in Mixamo’s library by clicking on
the thumbnails in the left window. You will see the
animation play on your avatar on the right.

When you’re happy with your animation choice, click on
the Download button on the top-right.

Keep most settings on default. For the “Skin” option, select
“Without Skin”. This will download an animation data file
without including the character model.

The file will download automatically to your computer. Find
the file in your “Downloads” folder and rename it.

We recommend naming this file
“[file-name]_[animation-name]”.
(for example: MyAvatar_Walking.fbx)

You are now done with the “[file-name]_preMixamo” file.
Feel free to delete it if you do not want it on your computer.

Even if you follow your own naming conventions, make
sure to name your files to be able to differentiate between
them.

Self Check

Were you able to choose an animation to apply to your avatar, download all the necessary files, and rename them as suggested?



Step 5: Combine in UEFN

Preview
The final step of animating your avatar is compiling all the files in UEFN and bringing your avatar to life! Make sure all of your files are ready
to go and are named appropriately. It is very important to use the correct files while compiling your animation in this step.

Experiment

IMPORT ALL FILES

Open UEFN and create or open a project.

To begin, create three folders in your Content Drawer by
right clicking on an empty area. These will help you keep
track of the files you import. Name them:

● Animations
● Bones
● Materials

Open the “Materials” folder and import the .glb file named
“[filename]_TexturesOnly”. This file will be used
exclusively for the materials (colors and textures) of your
avatar.

You will not be using the “Mesh” or “Skeletal Mesh” files in
this folder, because we have another file for the “body” of
the avatar.



Open the “Bones” folder and import the
“[file-name]_Bones” .fbx file from Mixamo.

On the import screen, make sure no skeleton is selected.
Under the Mesh section, the Skeleton option should say
“None”.

If this option is pre-populated with a skeleton, you can
deselect it by clicking the small return arrow next to the
dropdown.

Scroll down to the Material section and make sure you
select “All Assets” under Search Location. With this, the
model will be able to find the materials you imported
previously to the “Materials” folder.

When done, click on Import All.



Next, open the “Animations” folder. This is where the
animation files will be imported.

Click on “Import” and select your animated FBX files from
Mixamo named “[file-name]_[animation-name].”

In the Mesh tab, next to the Skeleton option, make sure to
select the skeleton that you’ve downloaded from Mixamo
with the “[file-name]_Bones” name. The name of the file
should automatically match the name of the skeleton.

Select Import All when done.

In the “Bones” folder, drag the Skeletal Mesh asset onto
your island. This asset will be underlined in pink in the
thumbnail.

This asset is just the skin and bones of your avatar and
does not have animations yet.



Select your skeletal mesh in the Viewport and go to the
Details Panel.

Under the Animation tab, find “Anim to Play.” Open the
dropdown and select the animation you want to apply to
your avatar.

Your avatar skeletal mesh will be positioned to the first
frame of the animation but will not move in the Viewport.

To see the animation play in real time, Launch Session
and open your island in Fortnite.

Self Check

Could you animate your avatar as you wanted?



Lesson Closure

Demonstration of Learning
In this Guide, you’ve learned how to create your own avatar in Ready Player Me and animate it using Blender and Mixamo. Paying attention
to different file types and names, you’ve compiled all of the files in UEFN to bring your avatar to life with animations.

Exploration Opportunities
Learning how to animate avatars or different characters can open a whole new world of 3D creation for you. After understanding the basics
of character animation, you can apply the skills you’ve learned into animating any kind of character you want in your 3D experiences.

Check out the following Learning Guides to learn how to animate photogrammetry models of people or inanimate objects and cameras in
UEFN:

Animate Photogrammetry Models of People Learning Guide
Animate Assets and Cameras in UEFN Learning Guide

https://www.youtube.com/watch?v=iyWDNp1jLss
https://www.youtube.com/watch?v=F3Vg_JW7sUg

