
Learning Guide
Create and Edit Photorealistic Models

Introduction
You can create models of real-world objects to add to 3D experiences. This Guide will introduce you to two different tools—Polycam and
Luma 3D Capture—that you can use to create realistic models of objects in your environment using a cell phone or tablet. The models you
create can be added to a range of 3D experiences, including Fortnite islands using Unreal Editor for Fortnite (UEFN).

This Guide focuses on a few specific approaches for making 3D models with each tool, and provides strategies for editing models created
with each tool so they can be used in a 3D experience.

Video Learning Guide for this Lesson:
https://www.youtube.com/watch?v=dcb7UtEFjTA
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Step 1 (Option 1): Create photogrammetry models with Polycam

Preview
Photogrammetry is a technique that stitches together multiple overlapping photos of an object or environment to create a 3D model. The 3D
models are typically highly detailed and realistic-looking. Polycam is a multi-platform app that lets users create photogrammetry models of
objects and people easily.

Experiment

PREPARE TO SCAN

Locate a mobile device with a camera. Install the Polycam
app. You will need to create an account. You do not need
to accept the free trial or subscribe - you can decline and
begin making models for free.



CHOOSE SOMETHING TO SCAN

Because of the way photogrammetry stitches multiple
images together, not all objects will create a perfect 3D
model. Objects likely to scan well typically:

● have various textures, materials, and colors
● are not symmetrical
● are not reflective or transparent
● allow you to take photos from every angle

If you are scanning a person, ask them to wear
multicolored/patterned clothing with texture, and consider
wearing a hat/headband, rings, and other accessories. You
have some flexibility - just do your best to find an object
that has at least some of these characteristics.

FIND AN AREA TO COMPLETE YOUR
SCAN

Try to find an area with even, balanced lighting and
minimal shadows.

Choose a non-reflective background when possible - for
example, scanning an object on a wooden table will work
better than scanning on a glass one.



COMPLETE YOUR SCAN

Do not move the object or person you are scanning at any
point during the process. People being scanned should do
their best to be as still as possible, and should ideally
stand in an “A” pose.

Launch the Polycam app on your mobile device. The app
should launch in Capture Mode.

Select Photo Mode.

Choose either Auto Mode or Manual Mode.
● Auto Mode: the app will take photos for you

as you slowly move around the object
● Manual Mode: you will decide when to take

photos



Begin taking photos by clicking the white circular button.
Take photos from above, below, and all sides of the object
with at least 50% overlap between photos. Make sure you
take at least two overlapping photos of every area on the
object.

It’s ideal to take your photos in circles around the object so
you can be more certain that you’ve captured every area
on the object. Take extra photos of any areas with irregular
shapes, undersides, or more uniform textures or colors.

PROCESS YOUR SCAN

Click the “Done” button when you are finished taking
photos.

Click “Upload and Process.” Make sure to keep the app
open during processing.



EXPORT THE MODEL

To export your model, click the small download icon at the
top right of the screen.

Select GLTF and click “Export”.

Choose a location to export. For example, you can email
the file to yourself or save it to Google Drive.

Self Check
Were you able to scan the object you wanted? Try using multiple objects for photogrammetry scans and see which types of objects scan well
and which ones don’t. Trying to scan an object that you know may not scan well can be a great exercise to help you understand how
photogrammetry works.



Step 1 (Option 2): Create models using NeRFs with Luma 3D Capture

Preview
Luma 3D Capture allows you to create 3D models using neural radiance fields, or NeRFs. It can sometimes be a good alternative to
Polycam, especially when creating models of objects that are challenging to scan with photogrammetry technology (due to lack of details,
shininess, uniform colors/textures, etc).

Experiment

PREPARE TO SCAN

Locate a mobile device with a camera. Install the Luma 3D
Capture app. You will need to sign in with a Google
Account.

Choose something you would like to scan - a person or an
object. Choose something that can remain still during
scanning, with minimal background movement.



COMPLETE YOUR SCAN

Open the Luma 3D Capture app on your device. The app
might have a slightly different interface based on your
device.

If you are using an Apple device (left image), select the +
option at the bottom of the screen to start a capture.

If you are using an Android device (right image), select the
Create (+) option and choose Guided before following the
prompts to capture.

The Luma app is sensitive to device rotation, so it would be
beneficial to disable “Auto Rotate” by going to your mobile
device’s settings before starting your capture.

Keep in mind that the interface of the app and the prompts
on screen may differ depending on devices used. This
Guide will be showing examples from an iOS device.

Follow the prompts on screen and tap on the middle area
of your object on the front and back to create a rectangular
volume that will cover the entirety of your selected object.



Then follow the on-screen guides to walk around your
object multiple times while positioning your phone at
different angles and heights.

The guides on screen will change color as you cover the
required angles. When you capture all sides of your object,
your capture will be complete.

PROCESS YOUR SCAN

Once finished, change the title of your scan and click on
Upload.

The app will then begin to upload and process your scan.
The process might take a few minutes depending on the
app’s current capacity.



EXPORT THE MODEL

When the model has finished processing, you can access
the model via the Profile section within the app.

Scroll to the bottom of the screen to the Assets section.

Select the GLTF option to download the model. The
downloaded model will be saved to your mobile device.

You can upload the model to Google Drive or email it to
yourself to access it from a computer.

Self Check
Try scanning the same object or person with Polycam and Luma 3D Capture. What do you think the strengths and weaknesses are for each
app?



Step 3: Edit models in Blender

Preview
Creating a photorealistic model of an object will naturally include parts of the surrounding environment - usually the surface that the object
was standing on. You can use additional tools and softwares to edit or “clean up” your model before its final use.

Experiment

EDIT THE MODEL IN BLENDER

Blender is a free, commonly-used 3D creation suite that
can be used in many areas of 3D creation. For this lesson,
you will need to use a few functions in Blender to clean up
your 3D model.

Download the model file to your computer. If you have a
zip file, extract the file in the File Explorer.

Download Blender and follow the prompts to install it on
your computer. Once installed, launch Blender and select
General from the New File options.

https://www.blender.org/download/


To navigate in the Blender viewport, hold down the SHIFT
key and Middle Mouse Button together and move your
mouse.

To rotate around an object, hold down Middle Mouse
Button and move your mouse in the viewport.

To zoom in or out, use the scroll wheel on your mouse or
hold down CTRL and use the Middle Mouse Button.

To move an object in the scene, you can enable the arrow
gizmos by selecting the “Move” icon from the left panel.

You will see some default objects (cube, camera, light) in
the Blender scene that opens. You can delete these
objects since they’re not needed.

Click on the “A” key to select everything in your scene
and press Delete (or the “X” key) to clear the scene.



Navigate to the File section and then Import > GLB/GLTF.
Select your downloaded 3D model.

Change the upper left hand dropdown from “Object Mode”
to Edit Mode.



Click and drag on the excess area you wish to get rid of
and press the Delete (or “X”) key to remove it. Select
Vertices from the pop up.

You might need to go over the same areas multiple times
to make sure all vertices are deleted.

You can also use different tools to select larger areas. After
going into Edit Mode, and access Select > Box Select or
Select > Circle Select. Select the area you want to delete
and hit the DELETE key.



Once satisfied with your model, navigate to File > Export.
Pick either FBX or GLB/GLTF and export your model.

Name your download file and remember where you saved
it on your computer for the next steps.

Self Check
At the end of this step, you should have a clean 3D model that doesn’t include extra area from its surroundings. What have you found during
your editing process that worked well and that didn’t?



Step 4: Import models into UEFN

Preview
Now that your models are cleaned up and ready to use, you can bring them into Unreal Editor For Fortnite (UEFN) and add them to your
Fortnite experience.

Experiment

IMPORT YOUR MODEL INTO UEFN

Launch UEFN and open an existing project or create a
new one.

Open the Content Drawer and select your project’s folder.
Click the Import button. You can also right click in the
Content Drawer and select the “Import” option.

Navigate to the location on your computer where you
saved your model and select it. You can leave all settings
at default and click “Import” to bring your model into the
Content Drawer.



Find your imported model in the Content Drawer. It will be
labeled as Static Mesh with an aqua-color line under the
thumbnail.

Click on the thumbnail and drag it into the Viewport to
bring the model onto your island.

You can use the transform tools in UEFN to place your 3D
model wherever you wish on your island and scale it as
much as you want.

Enable the Transform gizmos (Move, Rotate, Scale)
using the icons near the top right of the Viewport. You can
also use keyboard shortcuts: Move (W), Rotate (E), Scale
(R).

With each gizmo, use the handles to transform your asset.
The “Move gizmo” will help you position your asset across
your island, the “Rotate gizmo” will rotate it on 3 different
axes, and the “Scale gizmo” will make your asset smaller
or larger.

To change the size of your asset uniformly in all directions,
hover your mouse over the cube at the center of the Scale
gizmo until all handles turn yellow, then click and drag to
scale.



When you’re ready to see your model within the Fortnite
session, click on the Launch Session button at the top of
the Viewport.

After the session loads, you will be able to look at the
photorealistic model you’ve added to your island.

Self Check
Could you import your model into UEFN and position it as you wanted?



Lesson Closure

Demonstration of Learning
You’ve learned about 3D scanning techniques and learned how to use two different tools called Polycam and Luma 3D Capture. You created
a 3D model of a real-life object or a person and successfully brought it onto a Fortnite island created using UEFN.

Exploration Opportunities
You can scan as many objects or people as you want and populate your Fortnite island with things important to you or to create a cohesive
island experience. The skills you’ve learned in this Guide will help you quickly create 3D assets when you can’t find exactly what you’re
looking for in online asset libraries.

If you’d like to combine the 3D models you’ve scanned with other 3D models you create or find online, check out the following lessons:
Pre-Made Asset Libraries Learning Guide
Pre-Made Assets in UEFN Learning Guide
Artist Designed Models in UEFN Learning Guide

http://poly.cam
http://lumalabs.ai/
https://www.youtube.com/watch?v=O0826xI_sH8
https://www.youtube.com/watch?v=x1722cZ31OE
https://www.youtube.com/watch?v=MyHYfDvrWXw

